Security Alert! WordPress released version 3.9 this week and your WP core should update automatically.  However, it is important to keep your plugins up to date (this is done manually).  Due to a security breach, the plugin, Jetpack, needs to be updated to 2.9.3 immediately.

Jetpack has released a critical security update for their plugin. In a recent security audit, Jetpack discovered a vulnerability in their plugin that would allow an attacker to bypass a site’s access controls and publish posts to your WordPress installation(s).

To check this, login to your WordPress admin control panel and click on Plugins (located on the left panel). Scroll down and find Jetpack in the list, the version number will be listed in the description. If a WordPress plugin update is available, it will be shown on the Dashboard Panel, an alert on the Plugin’s menu title, and on the Plugin List.

For more information on the Jetpack critical security update, visit http://jetpack.me/2014/04/10/jetpack-security-update/.